Eco-Logic - Troubleshooting Guide

Problem

Display indicates watering but none is occurring.

Cause

Faulty or miswired valve.
Faulty pump or pump relay.
No water pressure to system.

Solution

Check valve and valve wiring.
Check pump and pump relay. Replace if defective.
Turn on main system water supply.

Problem

Time of day display is blinking.

Cause

Unit has just been powered up for the first time.
Extended power outage has occurred that has drained backup battery.

Solution

Set time/date.
Replace battery and reprogram controller.

Problem

Valve will not turn on.

Cause

Short in wire connections.
Bad solenoid.

Solution

Check wiring for short or faulty wire connections.
Replace solenoid.

Problem

Display shows “ERR” with a number (1-6).

Cause

Short in valve wiring circuit; or a faulty solenoid on the station number indicated.

Solution

Check wire circuit or solenoid for the valve number indicated. Repair short or replace solenoid. Press any button to clear “ERR” display.

Problem

Display shows “P ERR”.

Cause

Faulty pump relay or master valve wiring.
Incompatible or defective pump relay.

Solution

Check wiring to relay or master valve solenoid. Press any button to clear “P ERR” from the display.
Check electrical specifications of pump relay. Replace if defective.

Problem

The display reads “No AC”.

Cause

There is no AC power present.

Solution

Check to make sure power is on. Check to see if transformer is properly installed.

Problem

Rain Sensor does not suspend irrigation.

Cause

Rain sensor is defective or miswired.
Jumper not removed.

Solution

Verify operation of sensor and proper wiring.
Remove jumper.

Problem

Frozen Display, or display showing incorrect information.

Cause

Power surge.

Solution

Reset controller per “Clearing Controllers Memory/Resetting the Controller”.

Problem

Automatic irrigation does not start at start time and controller is not in the system off mode.

Cause

AM/PM of time of day not set correctly.
AM/PM of start time not set correctly.
Start time is disabled (Set for Off).
Controller is not receiving AC power.

Solution

Correct AM/PM of time of day.
Correct AM/PM of start time. Set start time.
See “Setting Watering Start Times”.
Check AC connections.

Problem

Controller waters the same area more than one time/Controller cycles continuously.

Cause

Too many start times entered in program (user error).

Solution

One start time activates a complete cycle. See “Setting Watering Start Times”.

Still need help? We're here.

Tell us what you need support with and we'll find the best solution for you.

Contact Support